Rig Welder Forums  

Go Back   Rig Welder Forums > Machines, tools, etc.

Reply
 
Thread Tools Display Modes
  #31  
Old 09-01-2014, 06:51 PM
dieselwelder dieselwelder is offline
Senior Member
 
Join Date: Nov 2011
Location: Springhill, Fl.... Home.
Posts: 723
Re: classic II or sa250D????

The click you hear when you turn the switch on is the fuel solenoid opening..which is good.. have you tried manually jumping the starter ? My oil pressure gauge doesn't work either but my machine runs fine.
__________________
I came here to chew bubble gum and kick ass. ...... and I'm all out of bubble gum !!
Reply With Quote
  #32  
Old 09-02-2014, 08:38 AM
WELDO WELDO is offline
Senior Member
 
Join Date: Dec 2013
Location: Southern NJ
Posts: 2,128
Re: classic II or sa250D????

Quote:
Originally Posted by xraywelder View Post
Yea i put a new ampress guage on the front just a universal from napa fpr some reason i think its that. And my oil pressure guage is real crusty n beat up. Im going to the deutz dealer after work tomorrow to get the correct ones. I flick the switch on and it clicks like it should then i press the start button n nothing. No clicks nothing. Then i flick the switch off then on again and the red engine protection light comes on then flick it off again, wait 3-5 seconds n it does it all over again
Everything there ties into a tattle tail/Murphy switch!! If your not properly grounded or have a short in the ground that will cause a problem. There is also a small fuse on the back side of the Murphy so make certain its good. I would test the start button for 12 volts cause the engine will turn over regardless. But if you dont have power to the start button back to starter solenoid nothing will happen! It is likely you do not have a good hot connection there. To check fuel pump you can loosen fuel line downstream and flip start switch and see if fuel is pushing out. Fuel pump runs when switch is in the on position. That is the system ground switch
__________________
Really Im not lying this time!

Last edited by WELDO; 09-02-2014 at 09:01 AM.
Reply With Quote
  #33  
Old 09-02-2014, 06:14 PM
xraywelder xraywelder is offline
Senior Member
 
Join Date: Aug 2014
Location: north dakota
Posts: 162
Re: classic II or sa250D????

Yea it doesnt even spark when i try to arc the solenoid on the starter. So i need to chexk that switch and fuse i guess. Its dark out now so ill try again tomorrow i guess. Its just crazy
Reply With Quote
  #34  
Old 09-08-2014, 06:43 PM
Stick-man Stick-man is offline
Member
 
Join Date: Sep 2011
Posts: 38
Re: classic II or sa250D????

Are there any timing belts on a 912 Deutz?
__________________
"Stick-man"

'00 Lincoln Commander 500
'75 SA200 round barrel
'80 SA250D
Reply With Quote
  #35  
Old 09-08-2014, 06:55 PM
xraywelder xraywelder is offline
Senior Member
 
Join Date: Aug 2014
Location: north dakota
Posts: 162
Wink Re: classic II or sa250D????

Yea. My push button was bad guys. Its purrrrs like a kitten again. I put a new starter on it too. Thanks for all the help guys. Im sure it wont be the last time!
Reply With Quote
  #36  
Old 09-09-2014, 03:55 AM
dieselwelder dieselwelder is offline
Senior Member
 
Join Date: Nov 2011
Location: Springhill, Fl.... Home.
Posts: 723
Re: classic II or sa250D????

Quote:
Originally Posted by Stick-man View Post
Are there any timing belts on a 912 Deutz?
I don't believe so... The belt is on the FL3 1011 or FL3 2011 engines.
__________________
I came here to chew bubble gum and kick ass. ...... and I'm all out of bubble gum !!
Reply With Quote
Reply

Tags
classic ii, sa250

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.